/[wait]/branches/unido/debian/rules
This is repository of my old source code which isn't updated any more. Go to git.rot13.org for current projects!
ViewVC logotype

Contents of /branches/unido/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 106 - (show annotations)
Tue Jul 13 12:22:09 2004 UTC (19 years, 9 months ago) by dpavlin
File size: 1825 byte(s)
Changes made by Andreas J. Koenig <andreas.koenig(at)anima.de> for Unido project

1 #!/usr/bin/make -f
2 # Made with the aid of debmake, by Christoph Lameter,
3 # based on the sample debian/rules file for GNU hello by Ian Jackson.
4
5 package=wait
6
7 ifndef PERL
8 PERL = /usr/bin/perl
9 endif
10
11 TMP =`pwd`/debian/tmp
12 archlib =`$(PERL) -MConfig -e 'print $$Config{installarchlib}'`
13 config =INSTALLDIRS=perl INSTALLMAN1DIR=$(TMP)/usr/share/man/man1 INSTALLMAN3DIR=$(TMP)/usr/share/man/man3 INSTALLPRIVLIB=$(TMP)/usr/lib/perl5 INSTALLARCHLIB=$(TMP)$(archlib) INSTALLSCRIPT=$(TMP)/usr/share/doc/wait/examples
14
15 build:
16 $(checkdir)
17 $(PERL) Makefile.PL -default $(config)
18 make
19
20 touch build
21
22 clean:
23 $(checkdir)
24 -rm -f build c-config.h
25 -make distclean
26 -rm Makefile Makefile.old
27 -rm -f `find . -name "*~"`
28 -rm -f `find . -name "*.o"`
29 -rm -f `find . -name "*.so"`
30 -rm -rf debian/tmp debian/files* core debian/substvars blib
31
32 binary-indep: checkroot build
33 $(checkdir)
34 # There are no architecture-independent files to be uploaded
35 # generated by this package. If there were any they would be
36 # made here.
37
38 binary-arch: checkroot build
39 $(checkdir)
40 -rm -rf debian/tmp
41 install -d debian/tmp
42 cd debian/tmp && install -d `cat ../dirs`
43 rm -rf blib/man1
44 rm -f blib/lib/WAIT/.cvsignore
45 cp debian/Config.pm blib/lib/WAIT/Config.pm
46 $(MAKE) pure_install
47 # Must have debmake installed for this to work. Otherwise please copy
48 # /usr/bin/debstd into the debian directory and change debstd to debian/debstd
49 #cp -p demo gdc `pwd`/debian/tmp/usr/share/doc/$(package)
50 dh_perl
51 debstd README
52 dpkg-gencontrol
53 chown -R root.root debian/tmp
54 chmod -R u=rwX,go=rX debian/tmp
55 dpkg --build debian/tmp ..
56
57 define checkdir
58 test -f debian/rules
59 endef
60
61 # Below here is fairly generic really
62
63 binary: binary-indep binary-arch
64
65 checkroot:
66 $(checkdir)
67 test root = "`whoami`"
68
69 .PHONY: binary binary-arch binary-indep clean checkroot

Properties

Name Value
svn:executable

  ViewVC Help
Powered by ViewVC 1.1.26